Mattermost GitHub Plugin Bot Identity Validation Bypass Allows Arbitrary GitHub Reaction Injection
CVE-2025-13352GHSA-jf5h-xfw4-p8gp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.11.7-0.20251106103514-3b05384dd014; github.com/mattermost/mattermost-plugin-github 1.0.1-0.20250829075715-0deffcfc6bee; github.com/mattermost/mattermost 11.1.0, 10.11.7-0.20251106103514-3b05384dd014), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 10.11.0-rc1, < 10.11.7-0.20251106103514-3b05384dd014
- Fixed in
- 10.11.7-0.20251106103514-3b05384dd014
Go github.com/mattermost/mattermost-plugin-github
- Affected
- < 1.0.1-0.20250829075715-0deffcfc6bee
- Fixed in
- 1.0.1-0.20250829075715-0deffcfc6bee
Go github.com/mattermost/mattermost
- Affected
- < 10.11.7-0.20251106103514-3b05384dd014>= 11.0.0-alpha.1, < 11.1.0
- Fixed in
- 10.11.7-0.20251106103514-3b05384dd014, 11.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf5h-xfw4-p8gp lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.11.0-rc1 =0 =11.0.0-alpha.1 =0 <1.0.1-0.20250829075715-0deffcfc6bee
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N
- EPSS
- CVE-2025-13352: 0.18% estimated exploitation activity in the next 30 days; percentile 6.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.11.x <= 10.11.6 and Mattermost GitHub plugin versions <=2.4.0 fail to validate plugin bot identity in reaction forwarding which allows attackers to hijack the GitHub reaction feature to make users add reactions to arbitrary GitHub objects via crafted notification posts.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jf5h-xfw4-p8gp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13352 Advisory: Mattermost GitHub Plugin Bot Identity Validation Bypass Allows Arbitrary GitHub Reaction Injection IDs: CVE-2025-13352, GHSA-jf5h-xfw4-p8gp Record: https://patchnext.com/advisories/cve-2025-13352 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.11.7-0.20251106103514-3b05384dd014; github.com/mattermost/mattermost-plugin-github 1.0.1-0.20250829075715-0deffcfc6bee; github.com/mattermost/mattermost 11.1.0, 10.11.7-0.20251106103514-3b05384dd014. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 10.11.0-rc1, < 10.11.7-0.20251106103514-3b05384dd014; fixed in 10.11.7-0.20251106103514-3b05384dd014 - Go github.com/mattermost/mattermost-plugin-github: affected < 1.0.1-0.20250829075715-0deffcfc6bee; fixed in 1.0.1-0.20250829075715-0deffcfc6bee - Go github.com/mattermost/mattermost: affected < 10.11.7-0.20251106103514-3b05384dd014; >= 11.0.0-alpha.1, < 11.1.0; fixed in 10.11.7-0.20251106103514-3b05384dd014, 11.1.0 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-plugin-github: check the installed version with your package manager. - Go github.com/mattermost/mattermost: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-github, github.com/mattermost/mattermost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jf5h-xfw4-p8gp (GitHub-reviewed advisory GHSA-jf5h-xfw4-p8gp lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.11.0-rc1 =0 =11.0.0-alpha.1 =0 <1.0.1-0.20250829075715-0deffcfc6bee) Commands are suggestions: review each one before running it.
Loading voting…