Skip to content

← Actionable
Medium, CVSS 5.8

kube-controller-manager is vulnerable to half-blind Server Side Request Forgery through in-tree Portworx StorageClass

CVE-2025-13281GHSA-r6j8-c6r2-37rr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.34.2, 1.33.6, 1.32.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    < 1.32.10>= 1.33.0-alpha.0, < 1.33.6>= 1.34.0-alpha.0, < 1.34.2
    Fixed in
    1.34.2, 1.33.6, 1.32.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2025-13281: 0.39% estimated exploitation activity in the next 30 days; percentile 33.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A half-blind Server Side Request Forgery (SSRF) vulnerability exists in kube-controller-manager when using the in-tree Portworx StorageClass. This vulnerability allows authorized users to leak arbitrary information from unprotected endpoints in the control plane’s host network (including link-local or loopback services).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r6j8-c6r2-37rr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-13281

Advisory: kube-controller-manager is vulnerable to half-blind Server Side Request Forgery through in-tree Portworx StorageClass
IDs: CVE-2025-13281, GHSA-r6j8-c6r2-37rr
Record: https://patchnext.com/advisories/cve-2025-13281 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.34.2, 1.33.6, 1.32.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected < 1.32.10; >= 1.33.0-alpha.0, < 1.33.6; >= 1.34.0-alpha.0, < 1.34.2; fixed in 1.34.2, 1.33.6, 1.32.10

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r6j8-c6r2-37rr (GitHub-reviewed advisory GHSA-r6j8-c6r2-37rr lists affected ranges: Go k8s.io/kubernetes >=0 =1.33.0-alpha.0 =1.34.0-alpha.0 <1.34.2)

Commands are suggestions: review each one before running it.

Loading voting…