Skip to content

← Actionable
High, CVSS 7.3amended

expr-eval vulnerable to Prototype Pollution

CVE-2025-13204GHSA-8gw3-rxh4-v6jx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm expr-eval-fork

    Affected
    < 2.0.2
    Fixed in
    2.0.2
  • npm expr-eval

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-13204: 0.85% estimated exploitation activity in the next 30 days; percentile 58.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

npm package expr-eval is vulnerable to Prototype Pollution. An attacker with access to express eval interface can use JavaScript prototype-based inheritance model to achieve arbitrary code execution. The npm expr-eval-fork package resolves this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8gw3-rxh4-v6jx

  2. Revision 1 · created ·

    Published from osv record GHSA-8gw3-rxh4-v6jx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-13204

Advisory: expr-eval vulnerable to Prototype Pollution
IDs: CVE-2025-13204, GHSA-8gw3-rxh4-v6jx
Record: https://patchnext.com/advisories/cve-2025-13204 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: expr-eval-fork 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm expr-eval-fork: affected < 2.0.2; fixed in 2.0.2
- npm expr-eval: affected <= 2.0.2

## Suggested inspection (read-only)
- `npm ls expr-eval-fork --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls expr-eval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on expr-eval-fork, expr-eval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gw3-rxh4-v6jx (OSV record GHSA-8gw3-rxh4-v6jx lists affected ranges: npm expr-eval >=0 =0 <2.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-8gw3-rxh4-v6jx (GitHub-reviewed advisory GHSA-8gw3-rxh4-v6jx lists affected ranges: npm expr-eval >=0 =0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…