Drupal core allows Object Injection
CVE-2025-13081GHSA-m6vv-vcj8-w8m7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.2.8, 11.1.9, 10.5.6, 10.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.0.0, < 10.4.9>= 10.5.0, < 10.5.6>= 11.0.0, < 11.1.9>= 11.2.0, < 11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m6vv-vcj8-w8m7 lists affected ranges: Packagist drupal/core >=8.0.0 =10.5.0 =11.0.0 =11.2.0 <11.2.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-13081: 0.28% estimated exploitation activity in the next 30 days; percentile 20.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection. This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m6vv-vcj8-w8m7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13081 Advisory: Drupal core allows Object Injection IDs: CVE-2025-13081, GHSA-m6vv-vcj8-w8m7 Record: https://patchnext.com/advisories/cve-2025-13081 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.2.8, 11.1.9, 10.5.6, 10.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.0.0, < 10.4.9; >= 10.5.0, < 10.5.6; >= 11.0.0, < 11.1.9; >= 11.2.0, < 11.2.8; fixed in 10.4.9, 10.5.6, 11.1.9, 11.2.8 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m6vv-vcj8-w8m7 (GitHub-reviewed advisory GHSA-m6vv-vcj8-w8m7 lists affected ranges: Packagist drupal/core >=8.0.0 =10.5.0 =11.0.0 =11.2.0 <11.2.8) Commands are suggestions: review each one before running it.
Loading voting…