pgAdmin is affected by an LDAP injection vulnerability
CVE-2025-12764GHSA-cvf4-f829-762v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgadmin4 9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pgadmin4
- Affected
- <= 9.9
- Fixed in
- 9.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cvf4-f829-762v lists affected ranges: PyPI pgadmin4 >=0 <9.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvf4-f829-762v lists affected ranges: PyPI pgadmin4 >=0 <=9.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-12764: 0.48% estimated exploitation activity in the next 30 days; percentile 41.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cvf4-f829-762v
- Revision 1 · created ·
Published from osv record GHSA-cvf4-f829-762v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12764 Advisory: pgAdmin is affected by an LDAP injection vulnerability IDs: CVE-2025-12764, GHSA-cvf4-f829-762v Record: https://patchnext.com/advisories/cve-2025-12764 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pgadmin4 9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pgadmin4: affected <= 9.9; fixed in 9.10 ## Suggested inspection (read-only) - `python -m pip show pgadmin4`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pgadmin4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cvf4-f829-762v (OSV record GHSA-cvf4-f829-762v lists affected ranges: PyPI pgadmin4 >=0 <9.10 (fixed)) - Verified: https://github.com/advisories/GHSA-cvf4-f829-762v (GitHub-reviewed advisory GHSA-cvf4-f829-762v lists affected ranges: PyPI pgadmin4 >=0 <=9.9) Commands are suggestions: review each one before running it.
Loading voting…