Skip to content

← Actionable
High, CVSS 8.6amended

expr-eval does not restrict functions passed to the evaluate function

CVE-2025-12735GHSA-jc85-fpwf-qm7x

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm expr-eval-fork

    Affected
    <= 3.0.0
    Fixed in
    3.0.1
  • npm expr-eval

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-12735: 1.76% estimated exploitation activity in the next 30 days; percentile 78.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The expr-eval library is a JavaScript expression parser and evaluator designed to safely evaluate mathematical expressions with user-defined variables. However, due to insufficient input validation, an attacker can pass a crafted variables object into the evaluate() function and trigger arbitrary code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jc85-fpwf-qm7x

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jc85-fpwf-qm7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-12735

Advisory: expr-eval does not restrict functions passed to the evaluate function
IDs: CVE-2025-12735, GHSA-jc85-fpwf-qm7x
Record: https://patchnext.com/advisories/cve-2025-12735 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: expr-eval-fork 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm expr-eval-fork: affected <= 3.0.0; fixed in 3.0.1
- npm expr-eval: affected <= 2.0.2

## Suggested inspection (read-only)
- `npm ls expr-eval-fork --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls expr-eval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on expr-eval-fork, expr-eval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jc85-fpwf-qm7x (OSV record GHSA-jc85-fpwf-qm7x lists affected ranges: npm expr-eval >=0 =0 <3.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-jc85-fpwf-qm7x (GitHub-reviewed advisory GHSA-jc85-fpwf-qm7x lists affected ranges: npm expr-eval >=0 =0 <=3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…