Mattermost fails to check Websocket request for proper UTF-8 format potentially crashing Calls plug-in
CVE-2025-12689GHSA-j5vq-62gr-8v3r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-plugin-calls 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-plugin-calls
- Affected
- < 1.11.0
- Fixed in
- 1.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5vq-62gr-8v3r lists affected ranges: Go github.com/mattermost/mattermost-plugin-calls >=0 <1.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-12689: 0.29% estimated exploitation activity in the next 30 days; percentile 21.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.0.x <= 11.0.4, 10.12.x <= 10.12.2, 10.11.x <= 10.11.6 fail to check WebSocket request field for proper UTF-8 format, which allows attacker to crash Calls plug-in via sending malformed request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j5vq-62gr-8v3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12689 Advisory: Mattermost fails to check Websocket request for proper UTF-8 format potentially crashing Calls plug-in IDs: CVE-2025-12689, GHSA-j5vq-62gr-8v3r Record: https://patchnext.com/advisories/cve-2025-12689 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-plugin-calls 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-plugin-calls: affected < 1.11.0; fixed in 1.11.0 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-plugin-calls: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-plugin-calls. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j5vq-62gr-8v3r (GitHub-reviewed advisory GHSA-j5vq-62gr-8v3r lists affected ranges: Go github.com/mattermost/mattermost-plugin-calls >=0 <1.11.0) Commands are suggestions: review each one before running it.
Loading voting…