Quarkus REST Endpoint Request Parameter Leakage Due to Shared Instance
CVE-2025-1247GHSA-phg3-gv66-q38x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-rest 3.18.2, 3.15.3.1, 3.8.6.1; io.quarkus:quarkus-rest-deployment 3.18.2, 3.15.3.1, 3.8.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.quarkus:quarkus-rest
- Affected
- >= 3.16.0.CR1, < 3.18.2>= 3.9.0.CR1, < 3.15.3.1< 3.8.6.1
- Fixed in
- 3.8.6.1, 3.18.2, 3.15.3.1
Maven io.quarkus:quarkus-rest-deployment
- Affected
- >= 3.16.0.CR1, < 3.18.2>= 3.9.0.CR1, < 3.15.3.1< 3.8.6.1
- Fixed in
- 3.8.6.1, 3.18.2, 3.15.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-phg3-gv66-q38x lists affected ranges: Maven io.quarkus:quarkus-rest >=3.16.0.CR1 =3.9.0.CR1 =0 =3.16.0.CR1 =3.9.0.CR1 =0 <3.8.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2025-1247: 0.82% estimated exploitation activity in the next 30 days; percentile 57.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Quarkus REST that allows request parameters to leak between concurrent requests if endpoints use field injection without a CDI scope. This vulnerability allows attackers to manipulate request data, impersonate users, or access sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-phg3-gv66-q38x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-1247 Advisory: Quarkus REST Endpoint Request Parameter Leakage Due to Shared Instance IDs: CVE-2025-1247, GHSA-phg3-gv66-q38x Record: https://patchnext.com/advisories/cve-2025-1247 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-rest 3.18.2, 3.15.3.1, 3.8.6.1; io.quarkus:quarkus-rest-deployment 3.18.2, 3.15.3.1, 3.8.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.quarkus:quarkus-rest: affected >= 3.16.0.CR1, < 3.18.2; >= 3.9.0.CR1, < 3.15.3.1; < 3.8.6.1; fixed in 3.8.6.1, 3.18.2, 3.15.3.1 - Maven io.quarkus:quarkus-rest-deployment: affected >= 3.16.0.CR1, < 3.18.2; >= 3.9.0.CR1, < 3.15.3.1; < 3.8.6.1; fixed in 3.8.6.1, 3.18.2, 3.15.3.1 ## Suggested inspection (read-only) - Maven io.quarkus:quarkus-rest: check the installed version with your package manager. - Maven io.quarkus:quarkus-rest-deployment: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.quarkus:quarkus-rest, io.quarkus:quarkus-rest-deployment. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-phg3-gv66-q38x (GitHub-reviewed advisory GHSA-phg3-gv66-q38x lists affected ranges: Maven io.quarkus:quarkus-rest >=3.16.0.CR1 =3.9.0.CR1 =0 =3.16.0.CR1 =3.9.0.CR1 =0 <3.8.6.1) Commands are suggestions: review each one before running it.
Loading voting…