Skip to content

← Actionable
Critical, CVSS 9.9

Mattermost fails to to verify the token used during code exchange

CVE-2025-12421GHSA-mp6x-97xj-9x62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20251022210333-acda1fb5dd46; github.com/mattermost/mattermost-server 11.0.3, 10.12.2, 10.11.5, 10.5.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-mp6x-97xj-9x62 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =11.0.0 =10.12.0 =10.11.0 =10.5.0 <10.5.13

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-12421: 0.45% estimated exploitation activity in the next 30 days; percentile 38.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mp6x-97xj-9x62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-12421

Advisory: Mattermost fails to to verify the token used during code exchange
IDs: CVE-2025-12421, GHSA-mp6x-97xj-9x62
Record: https://patchnext.com/advisories/cve-2025-12421 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20251022210333-acda1fb5dd46; github.com/mattermost/mattermost-server 11.0.3, 10.12.2, 10.11.5, 10.5.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20251022210333-acda1fb5dd46; fixed in 8.0.0-20251022210333-acda1fb5dd46
- Go github.com/mattermost/mattermost-server: affected >= 11.0.0, < 11.0.3; >= 10.12.0, < 10.12.2; >= 10.11.0, < 10.11.5; >= 10.5.0, < 10.5.13; fixed in 10.12.2, 10.11.5, 11.0.3, 10.5.13

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mp6x-97xj-9x62 (GitHub-reviewed advisory GHSA-mp6x-97xj-9x62 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =11.0.0 =10.12.0 =10.11.0 =10.5.0 <10.5.13)

Commands are suggestions: review each one before running it.

Loading voting…