Bouncy Castle Vulnerable to Uncontrolled Resource Consumption
CVE-2025-12194GHSA-jv6h-4262-q663
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bc-fips 2.1.2; org.bouncycastle:bcprov-debug-lts8on 2.73.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bc-fips
- Affected
- >= 2.1.0, <= 2.1.1
- Fixed in
- 2.1.2
Maven org.bouncycastle:bcprov-debug-lts8on
- Affected
- >= 2.73.0, <= 2.73.7
- Fixed in
- 2.73.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jv6h-4262-q663 lists affected ranges: Maven org.bouncycastle:bc-fips >=2.1.0 =2.73.0 <=2.73.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:N/R:U/V:C/RE:M/U:Amber · score source
- EPSS
- CVE-2025-12194: 0.16% estimated exploitation activity in the next 30 days; percentile 4.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java FIPS bc-fips on All (API modules), Legion of the Bouncy Castle Inc. Bouncy Castle for Java LTS bcprov-lts8on on All (API modules) allows Excessive Allocation. This vulnerability is associated with program files core/src/main/jdk1.9/org/bouncycastle/crypto/fips/AESNativeCFB.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/fips/AESNativeGCM.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/fips/SHA256NativeDigest.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/fips/AESNativeEngine.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/fips/AESNativeCBC.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/fips/AESNativeCTR.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/engines/AESNativeCFB.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/engines/AESNativeGCM.Java, core/src/main/jdk1.9/org/bouncycastle/crypto/engines/AESNativeEngine.Java,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jv6h-4262-q663
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12194 Advisory: Bouncy Castle Vulnerable to Uncontrolled Resource Consumption IDs: CVE-2025-12194, GHSA-jv6h-4262-q663 Record: https://patchnext.com/advisories/cve-2025-12194 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bc-fips 2.1.2; org.bouncycastle:bcprov-debug-lts8on 2.73.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bc-fips: affected >= 2.1.0, <= 2.1.1; fixed in 2.1.2 - Maven org.bouncycastle:bcprov-debug-lts8on: affected >= 2.73.0, <= 2.73.7; fixed in 2.73.8 ## Suggested inspection (read-only) - Maven org.bouncycastle:bc-fips: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-debug-lts8on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bc-fips, org.bouncycastle:bcprov-debug-lts8on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jv6h-4262-q663 (GitHub-reviewed advisory GHSA-jv6h-4262-q663 lists affected ranges: Maven org.bouncycastle:bc-fips >=2.1.0 =2.73.0 <=2.73.7) Commands are suggestions: review each one before running it.
Loading voting…