LZ4 Java Compression has Out-of-bounds memory operations which can cause DoS
CVE-2025-12183GHSA-vqf4-7m7x-wgfc
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.jpountz.lz4:lz4
- Affected
- <= 1.3.0
- Fixed in
- no fixed version recorded
Maven org.lz4:lz4-pure-java
- Affected
- <= 1.8.0
- Fixed in
- no fixed version recorded
Maven at.yawk.lz4:lz4-java
- Affected
- < 1.8.1
- Fixed in
- 1.8.1
Maven org.lz4:lz4-java
- Affected
- < 1.8.1
- Fixed in
- 1.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqf4-7m7x-wgfc lists affected ranges: Maven at.yawk.lz4:lz4-java >=0 =0 =0 =0 <=1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-12183: 0.75% estimated exploitation activity in the next 30 days; percentile 54.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Out-of-bounds memory operations in org.lz4:lz4-java 1.8.0 and earlier allow remote attackers to cause denial of service and read adjacent memory via untrusted compressed input. This is fixed in a forked release: at.yawk.lz4:lz4-java version 1.8.1. The original project has been archived: https://github.com/lz4/lz4-java, and Sonatype has added a redirect from org.lz4:lz4-java:1.8.1 to the new group ID.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vqf4-7m7x-wgfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12183 Advisory: LZ4 Java Compression has Out-of-bounds memory operations which can cause DoS IDs: CVE-2025-12183, GHSA-vqf4-7m7x-wgfc Record: https://patchnext.com/advisories/cve-2025-12183 (revision 1, source checked 26 Oct 2026, 16:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: at.yawk.lz4:lz4-java 1.8.1; org.lz4:lz4-java 1.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.jpountz.lz4:lz4: affected <= 1.3.0 - Maven org.lz4:lz4-pure-java: affected <= 1.8.0 - Maven at.yawk.lz4:lz4-java: affected < 1.8.1; fixed in 1.8.1 - Maven org.lz4:lz4-java: affected < 1.8.1; fixed in 1.8.1 ## Suggested inspection (read-only) - Maven net.jpountz.lz4:lz4: check the installed version with your package manager. - Maven org.lz4:lz4-pure-java: check the installed version with your package manager. - Maven at.yawk.lz4:lz4-java: check the installed version with your package manager. - Maven org.lz4:lz4-java: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.jpountz.lz4:lz4, org.lz4:lz4-pure-java, at.yawk.lz4:lz4-java, org.lz4:lz4-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vqf4-7m7x-wgfc (GitHub-reviewed advisory GHSA-vqf4-7m7x-wgfc lists affected ranges: Maven at.yawk.lz4:lz4-java >=0 =0 =0 =0 <=1.3.0) Commands are suggestions: review each one before running it.
Loading voting…