MongoDB driver extension affected by mongoc_bulk_operation_t's read of invalid memory
CVE-2025-12119GHSA-mwcc-7vpp-xmv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongodb/mongodb-extension 1.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mongodb/mongodb-extension
- Affected
- < 1.21.2
- Fixed in
- 1.21.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mwcc-7vpp-xmv9 lists affected ranges: Packagist mongodb/mongodb-extension >=0 <1.21.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2025-12119: 0.21% estimated exploitation activity in the next 30 days; percentile 11.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A mongocbulkoperationt may read invalid memory if large options are passed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mwcc-7vpp-xmv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12119 Advisory: MongoDB driver extension affected by mongoc_bulk_operation_t's read of invalid memory IDs: CVE-2025-12119, GHSA-mwcc-7vpp-xmv9 Record: https://patchnext.com/advisories/cve-2025-12119 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongodb/mongodb-extension 1.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mongodb/mongodb-extension: affected < 1.21.2; fixed in 1.21.2 ## Suggested inspection (read-only) - Packagist mongodb/mongodb-extension: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongodb/mongodb-extension. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mwcc-7vpp-xmv9 (GitHub-reviewed advisory GHSA-mwcc-7vpp-xmv9 lists affected ranges: Packagist mongodb/mongodb-extension >=0 <1.21.2) Commands are suggestions: review each one before running it.
Loading voting…