@react-native-community/cli has arbitrary OS command injection
CVE-2025-11953GHSA-399j-vxmf-hjvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@react-native-community/cli 20.0.0, 19.1.2, 18.0.1; @react-native-community/cli-server-api 20.0.0, 19.1.2, 18.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @react-native-community/cli
- Affected
- >= 20.0.0-alpha.0, < 20.0.0>= 19.0.0-alpha.0, < 19.1.2>= 18.0.0, < 18.0.1
- Fixed in
- 19.1.2, 18.0.1, 20.0.0
npm @react-native-community/cli-server-api
- Affected
- >= 20.0.0-alpha.0, < 20.0.0>= 19.0.0-alpha.0, < 19.1.2>= 18.0.0, < 18.0.1
- Fixed in
- 19.1.2, 18.0.1, 20.0.0
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-11953 to the Known Exploited Vulnerabilities catalog on 2026-02-05.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-02-05).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-399j-vxmf-hjvr lists affected ranges: npm @react-native-community/cli >=20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 =20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 <18.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-399j-vxmf-hjvr lists affected ranges: npm @react-native-community/cli >=20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 =20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 <18.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-11953: 93.98% estimated exploitation activity in the next 30 days; percentile 99.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Metro Development Server, which is opened by the React Native CLI, binds to external interfaces by default. The server exposes an endpoint that is vulnerable to OS command injection. This allows unauthenticated network attackers to send a POST request to the server and run arbitrary executables. On Windows, the attackers can also execute arbitrary shell commands with fully controlled arguments.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-399j-vxmf-hjvr
- Revision 2 · amended ·
Amended from osv record GHSA-399j-vxmf-hjvr
- Revision 1 · created ·
Published from ghsa record GHSA-399j-vxmf-hjvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-11953 Advisory: @react-native-community/cli has arbitrary OS command injection IDs: CVE-2025-11953, GHSA-399j-vxmf-hjvr Record: https://patchnext.com/advisories/cve-2025-11953 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: @react-native-community/cli 20.0.0, 19.1.2, 18.0.1; @react-native-community/cli-server-api 20.0.0, 19.1.2, 18.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @react-native-community/cli: affected >= 20.0.0-alpha.0, < 20.0.0; >= 19.0.0-alpha.0, < 19.1.2; >= 18.0.0, < 18.0.1; fixed in 19.1.2, 18.0.1, 20.0.0 - npm @react-native-community/cli-server-api: affected >= 20.0.0-alpha.0, < 20.0.0; >= 19.0.0-alpha.0, < 19.1.2; >= 18.0.0, < 18.0.1; fixed in 19.1.2, 18.0.1, 20.0.0 ## Suggested inspection (read-only) - `npm ls @react-native-community/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @react-native-community/cli-server-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @react-native-community/cli, @react-native-community/cli-server-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-11953 to the Known Exploited Vulnerabilities catalog on 2026-02-05.) - Verified: https://github.com/advisories/GHSA-399j-vxmf-hjvr (GitHub-reviewed advisory GHSA-399j-vxmf-hjvr lists affected ranges: npm @react-native-community/cli >=20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 =20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 <18.0.1) - Verified: https://osv.dev/vulnerability/GHSA-399j-vxmf-hjvr (OSV record GHSA-399j-vxmf-hjvr lists affected ranges: npm @react-native-community/cli >=20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 =20.0.0-alpha.0 =19.0.0-alpha.0 =18.0.0 <18.0.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…