Skip to content

← Actionable
Medium, CVSS 4.3

Mattermost fails to properly restrict access to archived channel search API

CVE-2025-11776GHSA-j6gg-r5jc-47cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250815165020-c8d66301415d; github.com/mattermost/mattermost-server/v6 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost-server 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost-server/v5 5.3.2-0.20250815165020-c8d66301415d), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j6gg-r5jc-47cm lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =0 =0 =0 =0 <5.3.2-0.20250815165020-c8d66301415d

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-11776: 0.21% estimated exploitation activity in the next 30 days; percentile 10.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions < 11 fail to properly restrict access to archived channel search API which allows guest users to discover archived public channels via the /api/v4/teams/{teamid}/channels/searcharchived endpoint

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j6gg-r5jc-47cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-11776

Advisory: Mattermost fails to properly restrict access to archived channel search API
IDs: CVE-2025-11776, GHSA-j6gg-r5jc-47cm
Record: https://patchnext.com/advisories/cve-2025-11776 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250815165020-c8d66301415d; github.com/mattermost/mattermost-server/v6 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost-server 5.3.2-0.20250815165020-c8d66301415d; github.com/mattermost/mattermost-server/v5 5.3.2-0.20250815165020-c8d66301415d. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250815165020-c8d66301415d; fixed in 8.0.0-20250815165020-c8d66301415d
- Go github.com/mattermost/mattermost-server/v6: affected < 5.3.2-0.20250815165020-c8d66301415d; fixed in 5.3.2-0.20250815165020-c8d66301415d
- Go github.com/mattermost/mattermost: affected < 5.3.2-0.20250815165020-c8d66301415d; fixed in 5.3.2-0.20250815165020-c8d66301415d
- Go github.com/mattermost/mattermost-server: affected < 5.3.2-0.20250815165020-c8d66301415d; fixed in 5.3.2-0.20250815165020-c8d66301415d
- Go github.com/mattermost/mattermost-server/v5: affected < 5.3.2-0.20250815165020-c8d66301415d; fixed in 5.3.2-0.20250815165020-c8d66301415d

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager.
- Go github.com/mattermost/mattermost: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j6gg-r5jc-47cm (GitHub-reviewed advisory GHSA-j6gg-r5jc-47cm lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =0 =0 =0 =0 <5.3.2-0.20250815165020-c8d66301415d)

Commands are suggestions: review each one before running it.

Loading voting…