Skip to content

← Actionable
High, CVSS 8.7

Amazon.IonDotnet is vulnerable to Denial of Service attacks

CVE-2025-11573GHSA-q5r6-9qwq-g2wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (amazon.iondotnet 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-11573: 0.43% estimated exploitation activity in the next 30 days; percentile 37.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Amazon.IonDotnet is a library for the Dotnet language that is used to read and write Amazon Ion data. An issue exists where, under certain circumstances, the library could an infinite loop, resulting in denial of service. As of August 20, 2025, this library has been deprecated and will not receive further updates. Impact An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. This invalid input triggered an error condition in the parser that was handled improperly, resulting in an infinite loop. Impacted versions: <1.3.2 Patches This issue has been addressed in Amazon.IonDotnet version 1.3.2. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Only accept data from trusted sources, written using a supported Ion library. References If you have any questions or comments about this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q5r6-9qwq-g2wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-11573

Advisory: Amazon.IonDotnet is vulnerable to Denial of Service attacks
IDs: CVE-2025-11573, GHSA-q5r6-9qwq-g2wj
Record: https://patchnext.com/advisories/cve-2025-11573 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: amazon.iondotnet 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet amazon.iondotnet: affected < 1.3.2; fixed in 1.3.2

## Suggested inspection (read-only)
- NuGet amazon.iondotnet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on amazon.iondotnet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q5r6-9qwq-g2wj (GitHub-reviewed advisory GHSA-q5r6-9qwq-g2wj lists affected ranges: NuGet amazon.iondotnet >=0 <1.3.2)

Commands are suggestions: review each one before running it.

Loading voting…