Skip to content

← Actionable
Medium, CVSS 5.0amended

Keycloak logs sensitive headers

CVE-2025-11537GHSA-gv3v-2cpp-3pmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-quarkus-server 26.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-11537: 0.17% estimated exploitation activity in the next 30 days; percentile 6.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Keycloak. When the logging format is configured to a verbose, user-supplied pattern (such as the pre-defined 'long' pattern), sensitive headers including Authorization and Cookie are disclosed to the logs in cleartext. An attacker with read access to the log files can extract these credentials (e.g., bearer tokens, session cookies) and use them to impersonate users, leading to a full account compromise. Patches are available, see: - https://github.com/keycloak/keycloak/releases/tag/26.4.11 - https://github.com/keycloak/keycloak/releases/tag/26.5.6 - https://github.com/keycloak/keycloak/releases/tag/26.6.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-gv3v-2cpp-3pmq

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-gv3v-2cpp-3pmq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gv3v-2cpp-3pmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-11537

Advisory: Keycloak logs sensitive headers
IDs: CVE-2025-11537, GHSA-gv3v-2cpp-3pmq
Record: https://patchnext.com/advisories/cve-2025-11537 (revision 3, source checked 31 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-quarkus-server 26.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-quarkus-server: affected < 26.5.6; fixed in 26.5.6

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-quarkus-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-quarkus-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gv3v-2cpp-3pmq (GitHub-reviewed advisory GHSA-gv3v-2cpp-3pmq lists affected ranges: Maven org.keycloak:keycloak-quarkus-server >=0 <26.5.6)
- Verified: https://osv.dev/vulnerability/GHSA-gv3v-2cpp-3pmq (OSV record GHSA-gv3v-2cpp-3pmq lists affected ranges: Maven org.keycloak:keycloak-quarkus-server >=0 <26.5.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…