org.eclipse.jetty:jetty-http has different parsing of invalid URIs
CVE-2025-11143GHSA-wjpw-4j6x-6rwh
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty:jetty-http
- Affected
- >= 9.4.0, <= 9.4.58>= 10.0.0, <= 10.0.26>= 11.0.0, <= 11.0.26>= 12.0.0, <= 12.0.30>= 12.1.0, <= 12.1.4
- Fixed in
- 12.0.31, 12.1.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wjpw-4j6x-6rwh lists affected ranges: Maven org.eclipse.jetty:jetty-http >=9.4.0 =10.0.0 =11.0.0 =12.0.0 =12.1.0 <=12.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2025-11143: 0.18% estimated exploitation activity in the next 30 days; percentile 7.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Jetty URI parser has some key differences compared to other common parsers when evaluating invalid or unusual URIs. Specifically: Invalid Scheme | URI | Jetty | uri-js (nodejs) | node-url(nodejs) | |---|---|---| --- | | https://vulndetector.com/path | scheme=http| scheme=https | invalid URI | Improper IPv4 mapped IPv6 | URI | Jetty | System.Uri(CSharp) | curl(C) | |---|---|---| --- | | http://[0:0:0:0:0:ffff:127.0.0.1] | invalid | host=[::ffff:127.0.0.1] | host=[::ffff:127.0.0.1] | | http://[::ffff:255.255.0.0] | invalid | host=[::ffff:255.255.0.0] | host=[::ffff:255.255.0.0] | Incorrect IPv6 delimeter priority | URI | Jetty | urllib3(python) | furl(python) | Spring | chromium | |---|---|---| --- |---|---| | http://[normal.com@]vulndetector.com/ | host=[normal.com@] | invalid | invalid | | | | http://normal.com[user@vulndetector].com/ | host=[noirmal.com@vulndetector | | | host=normal.com | invalid | | http://normal.com[@]vulndetector.com/ | host=normal.com[@] | | |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wjpw-4j6x-6rwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-11143 Advisory: org.eclipse.jetty:jetty-http has different parsing of invalid URIs IDs: CVE-2025-11143, GHSA-wjpw-4j6x-6rwh Record: https://patchnext.com/advisories/cve-2025-11143 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.eclipse.jetty:jetty-http 12.1.5, 12.0.31. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty:jetty-http: affected >= 9.4.0, <= 9.4.58; >= 10.0.0, <= 10.0.26; >= 11.0.0, <= 11.0.26; >= 12.0.0, <= 12.0.30; >= 12.1.0, <= 12.1.4; fixed in 12.0.31, 12.1.5 ## Suggested inspection (read-only) - Maven org.eclipse.jetty:jetty-http: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty:jetty-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wjpw-4j6x-6rwh (GitHub-reviewed advisory GHSA-wjpw-4j6x-6rwh lists affected ranges: Maven org.eclipse.jetty:jetty-http >=9.4.0 =10.0.0 =11.0.0 =12.0.0 =12.1.0 <=12.1.4) Commands are suggestions: review each one before running it.
Loading voting…