Skip to content

← Actionable
High, CVSS 8.7amended

xml2rfc has an arbitrary file read vulnerability

CVE-2025-11058GHSA-cfmv-h8fx-85m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xml2rfc 3.30.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI xml2rfc

    Affected
    <= 3.30.0
    Fixed in
    3.30.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact When generating PDF files, this vulnerability allows an attacker to read arbitrary files from the filesystem by injecting malicious link element into the XML. Workarounds Test untrusted input with link elements with rel="attachment" before processing. Credits This vulnerability was reported by Mohamed Ouad from Doyensec.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cfmv-h8fx-85m7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cfmv-h8fx-85m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-11058

Advisory: xml2rfc has an arbitrary file read vulnerability
IDs: CVE-2025-11058, GHSA-cfmv-h8fx-85m7
Record: https://patchnext.com/advisories/cve-2025-11058 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xml2rfc 3.30.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI xml2rfc: affected <= 3.30.0; fixed in 3.30.1

## Suggested inspection (read-only)
- `python -m pip show xml2rfc`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xml2rfc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cfmv-h8fx-85m7 (OSV record GHSA-cfmv-h8fx-85m7 lists affected ranges: PyPI xml2rfc >=0 <3.30.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cfmv-h8fx-85m7 (GitHub-reviewed advisory GHSA-cfmv-h8fx-85m7 lists affected ranges: PyPI xml2rfc >=0 <=3.30.0)

Commands are suggestions: review each one before running it.

Loading voting…