Skip to content

← Actionable
High, CVSS 7.8amended

Open Babel has heap buffer overflow in ChemKin ChemKinFormat::CheckSpecies

CVE-2025-10997GHSA-8wq6-qh76-wpv9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openbabel 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-10997: 0.29% estimated exploitation activity in the next 30 days; percentile 21.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A memory-safety vulnerability in Open Babel's ChemKin parser caused a heap buffer overflow when reading a crafted input file. Details The flaw was in ChemKinFormat::CheckSpecies. A malformed species record caused the parser to write past the end of a heap-allocated buffer. Impact Open Babel is a C++ library and CLI used to read and write chemistry file formats; it is shipped by Linux distributions and embedded in services that may parse untrusted input. Triggering this vulnerability requires the victim to open a malicious ChemKin file with the obabel tool, the OBConversion API, or any of the language bindings (Python, Ruby, Java, R, Perl, C#, PHP). Affected versions All releases up to and including 3.1.1. Patched version 3.2.0 (released 2026-05-26). Patch Fix commit: https://github.com/openbabel/openbabel/commit/af4a4212 Originally reported as #2830; fixes consolidated in #2913. A minimized reproducer for this CVE is checked in under test/files/fuzzregress/ and is exercised…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8wq6-qh76-wpv9

  2. Revision 1 · created ·

    Published from osv record GHSA-8wq6-qh76-wpv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-10997

Advisory: Open Babel has heap buffer overflow in ChemKin ChemKinFormat::CheckSpecies
IDs: CVE-2025-10997, GHSA-8wq6-qh76-wpv9
Record: https://patchnext.com/advisories/cve-2025-10997 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openbabel 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openbabel: affected < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `python -m pip show openbabel`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openbabel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8wq6-qh76-wpv9 (OSV record GHSA-8wq6-qh76-wpv9 lists affected ranges: PyPI openbabel >=0 <3.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8wq6-qh76-wpv9 (GitHub-reviewed advisory GHSA-8wq6-qh76-wpv9 lists affected ranges: PyPI openbabel >=0 <3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…