Skip to content

← Actionable
Low, CVSS 1.9amended

Open Babel has out-of-bounds write (overlapping memcpy) in zipstream basic_unzip_streambuf::underflow

CVE-2025-10995GHSA-8j3x-m868-cpw8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openbabel 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-10995: 0.26% estimated exploitation activity in the next 30 days; percentile 17.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A memory-safety vulnerability in Open Babel's bundled zipstream decompression code caused an out-of-bounds write via overlapping memcpy when reading a crafted gzip-compressed chemistry file. Details The flaw was in basicunzipstreambuf::underflow. The decompression buffer refill path invoked memcpy with overlapping source and destination regions, which is undefined behavior and produced out-of-bounds writes in practice. Any file format read through the gzip-wrapped reader was a potential trigger. Impact Open Babel is a C++ library and CLI used to read and write chemistry file formats; it is shipped by Linux distributions and embedded in services that may parse untrusted input. Triggering this vulnerability requires the victim to open a malicious gzip-compressed chemistry file with the obabel tool, the OBConversion API, or any of the language bindings (Python, Ruby, Java, R, Perl, C#, PHP). Affected versions All releases up to and including 3.1.1. Patched version 3.2.0…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8j3x-m868-cpw8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8j3x-m868-cpw8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-10995

Advisory: Open Babel has out-of-bounds write (overlapping memcpy) in zipstream basic_unzip_streambuf::underflow
IDs: CVE-2025-10995, GHSA-8j3x-m868-cpw8
Record: https://patchnext.com/advisories/cve-2025-10995 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openbabel 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openbabel: affected < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `python -m pip show openbabel`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openbabel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8j3x-m868-cpw8 (OSV record GHSA-8j3x-m868-cpw8 lists affected ranges: PyPI openbabel >=0 <3.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8j3x-m868-cpw8 (GitHub-reviewed advisory GHSA-8j3x-m868-cpw8 lists affected ranges: PyPI openbabel >=0 <3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…