@sequa-ai/sequa-mcp has Command Injection vulnerability
CVE-2025-10619GHSA-9pw5-wx67-q964
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sequa-ai/sequa-mcp 1.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.14
- Fixed in
- 1.0.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9pw5-wx67-q964 lists affected ranges: npm @sequa-ai/sequa-mcp >=0 <1.0.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pw5-wx67-q964 lists affected ranges: npm @sequa-ai/sequa-mcp >=0 <1.0.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-10619: 1.77% estimated exploitation activity in the next 30 days; percentile 78.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was detected in sequa-ai sequa-mcp up to 1.0.13. This affects the function redirectToAuthorization of the file src/helpers/node-oauth-client-provider.ts of the component OAuth Server Discovery. Performing manipulation results in os command injection. Remote exploitation of the attack is possible. The exploit is now public and may be used. Upgrading to version 1.0.14 is able to mitigate this issue. The patch is named e569815854166db5f71c2e722408f8957fb9e804. It is recommended to upgrade the affected component. The vendor explains: "We only promote that mcp server with our own URLs that have a valid response, but yes if someone would use it with a non sequa url, this is a valid attack vector. We have released a new version (1.0.14) that fixes this and validates that only URLs can be opened."
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9pw5-wx67-q964
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9pw5-wx67-q964
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-10619 Advisory: @sequa-ai/sequa-mcp has Command Injection vulnerability IDs: CVE-2025-10619, GHSA-9pw5-wx67-q964 Record: https://patchnext.com/advisories/cve-2025-10619 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sequa-ai/sequa-mcp 1.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sequa-ai/sequa-mcp: affected < 1.0.14; fixed in 1.0.14 ## Suggested inspection (read-only) - `npm ls @sequa-ai/sequa-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sequa-ai/sequa-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9pw5-wx67-q964 (OSV record GHSA-9pw5-wx67-q964 lists affected ranges: npm @sequa-ai/sequa-mcp >=0 <1.0.14 (fixed)) - Verified: https://github.com/advisories/GHSA-9pw5-wx67-q964 (GitHub-reviewed advisory GHSA-9pw5-wx67-q964 lists affected ranges: npm @sequa-ai/sequa-mcp >=0 <1.0.14) Commands are suggestions: review each one before running it.
Loading voting…