Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0
CVE-2025-1057GHSA-9jxq-5x44-gx23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keylime 7.12.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keylime
- Affected
- >= 7.12.0, <= 7.12.0
- Fixed in
- 7.12.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9jxq-5x44-gx23 lists affected ranges: PyPI keylime >=7.12.0 <7.12.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jxq-5x44-gx23 lists affected ranges: PyPI keylime >=7.12.0 <=7.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-1057: 0.40% estimated exploitation activity in the next 30 days; percentile 34.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Keylime registrar implemented more strict type checking on version 7.12.0. As a result, when updated to version 7.12.0, the registrar will not accept the format of the data previously stored in the database by versions = 7.8.0, raising an exception. This makes the Keylime registrar vulnerable to a Denial-of-Service attack in an update scenario, as an attacker could populate the registrar database by creating multiple valid agent registrations with different UUIDs while the version is still < 7.12.0. Then, when the Keylime registrar is updated to the 7.12.0 version, any query to the database matching any of the entries populated by the attacker will result in failure. Patches Users should upgrade to versions = 7.12.1 Workarounds - Remove the registrar database and re-register all agents Credit Reported by: Anderson Toshiyuki Sasaki/@ansasaki Patched by: Anderson Toshiyuki Sasaki/@ansasaki
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9jxq-5x44-gx23
- Revision 1 · created ·
Published from osv record GHSA-9jxq-5x44-gx23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-1057 Advisory: Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0 IDs: CVE-2025-1057, GHSA-9jxq-5x44-gx23 Record: https://patchnext.com/advisories/cve-2025-1057 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keylime 7.12.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keylime: affected >= 7.12.0, <= 7.12.0; fixed in 7.12.1 ## Suggested inspection (read-only) - `python -m pip show keylime`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keylime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9jxq-5x44-gx23 (OSV record GHSA-9jxq-5x44-gx23 lists affected ranges: PyPI keylime >=7.12.0 <7.12.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9jxq-5x44-gx23 (GitHub-reviewed advisory GHSA-9jxq-5x44-gx23 lists affected ranges: PyPI keylime >=7.12.0 <=7.12.0) Commands are suggestions: review each one before running it.
Loading voting…