Skip to content

← Actionable
Medium, CVSS 4.7amended

BBOT's git_clone.py can expose users' GitHub API keys to an attacker-controlled webserver

CVE-2025-10281GHSA-63wh-p5fx-h4vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bbot 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bbot

    Affected
    < 2.7.0
    Fixed in
    2.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-10281: 0.23% estimated exploitation activity in the next 30 days; percentile 13.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to unsafe URL handling, bbot's gitclone.py can be made to leak a user's github.com API key to an attacker-controlled webserver. Impact A user who has placed their github.com API key in the configuration for any of the following modules: githubcodesearch githubworkflows gitlab gitclone githubusersearch githuborg may leak it to an untrustworthy server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-63wh-p5fx-h4vc

  2. Revision 1 · created ·

    Published from osv record GHSA-63wh-p5fx-h4vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-10281

Advisory: BBOT's git_clone.py can expose users' GitHub API keys to an attacker-controlled webserver
IDs: CVE-2025-10281, GHSA-63wh-p5fx-h4vc
Record: https://patchnext.com/advisories/cve-2025-10281 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bbot 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bbot: affected < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- `python -m pip show bbot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-63wh-p5fx-h4vc (OSV record GHSA-63wh-p5fx-h4vc lists affected ranges: PyPI bbot >=0 <2.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-63wh-p5fx-h4vc (GitHub-reviewed advisory GHSA-63wh-p5fx-h4vc lists affected ranges: PyPI bbot >=0 <2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…