mlflow Creates of Temporary File in Directory with Insecure Permissions
CVE-2025-10279GHSA-4x5p-f36r-mxxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.4.0rc0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- < 3.4.0rc0
- Fixed in
- 3.4.0rc0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4x5p-f36r-mxxr lists affected ranges: PyPI mlflow >=0 <3.4.0rc0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x5p-f36r-mxxr lists affected ranges: PyPI mlflow >=0 <3.4.0rc0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-10279: 0.24% estimated exploitation activity in the next 30 days; percentile 15.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In mlflow version 2.20.3, the temporary directory used for creating Python virtual environments is assigned insecure world-writable permissions (0o777). This vulnerability allows an attacker with write access to the /tmp directory to exploit a race condition and overwrite .py files in the virtual environment, leading to arbitrary code execution. The issue is resolved in version 3.4.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4x5p-f36r-mxxr
- Revision 1 · created ·
Published from osv record GHSA-4x5p-f36r-mxxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-10279 Advisory: mlflow Creates of Temporary File in Directory with Insecure Permissions IDs: CVE-2025-10279, GHSA-4x5p-f36r-mxxr Record: https://patchnext.com/advisories/cve-2025-10279 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 3.4.0rc0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected < 3.4.0rc0; fixed in 3.4.0rc0 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4x5p-f36r-mxxr (OSV record GHSA-4x5p-f36r-mxxr lists affected ranges: PyPI mlflow >=0 <3.4.0rc0 (fixed)) - Verified: https://github.com/advisories/GHSA-4x5p-f36r-mxxr (GitHub-reviewed advisory GHSA-4x5p-f36r-mxxr lists affected ranges: PyPI mlflow >=0 <3.4.0rc0) Commands are suggestions: review each one before running it.
Loading voting…