Skip to content

← Actionable
High, CVSS 7.4amended

Neo4j Cypher MCP server is vulnerable to DNS rebinding

CVE-2025-10193GHSA-vcqx-v2mg-7chx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-neo4j-cypher 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.4 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-10193: 0.22% estimated exploitation activity in the next 30 days; percentile 12.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact DNS rebinding vulnerability in Neo4j Cypher MCP server allows malicious websites to bypass Same-Origin Policy protections and execute unauthorised tool invocations against locally running Neo4j MCP instances. The attack relies on the user being enticed to visit a malicious website and spend sufficient time there for DNS rebinding to succeed. Patches CORS Middleware added to Cypher MCP server v0.4.0 that blocks all web-based access by default. Workarounds If you cannot upgrade to v0.4.0 and above, use stdio mode. References Vendor Advisory https://www.cve.org/CVERecord?id=CVE-2025-10193 Credits We want to publicly recognize the contribution of Evan Harris from mcpsec.dev for reporting this issue and following the responsible disclosure policy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vcqx-v2mg-7chx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vcqx-v2mg-7chx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-10193

Advisory: Neo4j Cypher MCP server is vulnerable to DNS rebinding
IDs: CVE-2025-10193, GHSA-vcqx-v2mg-7chx
Record: https://patchnext.com/advisories/cve-2025-10193 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-neo4j-cypher 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-neo4j-cypher: affected >= 0.2.2, < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- `python -m pip show mcp-neo4j-cypher`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-neo4j-cypher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vcqx-v2mg-7chx (OSV record GHSA-vcqx-v2mg-7chx lists affected ranges: PyPI mcp-neo4j-cypher >=0.2.2 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vcqx-v2mg-7chx (GitHub-reviewed advisory GHSA-vcqx-v2mg-7chx lists affected ranges: PyPI mcp-neo4j-cypher >=0.2.2 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…