SageMaker Workflow component allows possibility of MD5 hash collisions
CVE-2025-0508GHSA-32g6-mg92-ghm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sagemaker 2.237.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sagemaker
- Affected
- < 2.237.3
- Fixed in
- 2.237.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-32g6-mg92-ghm2 lists affected ranges: PyPI sagemaker >=0 <2.237.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-32g6-mg92-ghm2 lists affected ranges: PyPI sagemaker >=0 <2.237.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-0508: 0.27% estimated exploitation activity in the next 30 days; percentile 18.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the SageMaker Workflow component of aws/sagemaker-python-sdk allows for the possibility of MD5 hash collisions in all versions. This can lead to workflows being inadvertently replaced due to the reuse of results from different configurations that produce the same MD5 hash. This issue can cause integrity problems within the pipeline, potentially leading to erroneous processing outcomes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-32g6-mg92-ghm2
- Revision 1 · created ·
Published from osv record GHSA-32g6-mg92-ghm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-0508 Advisory: SageMaker Workflow component allows possibility of MD5 hash collisions IDs: CVE-2025-0508, GHSA-32g6-mg92-ghm2 Record: https://patchnext.com/advisories/cve-2025-0508 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sagemaker 2.237.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sagemaker: affected < 2.237.3; fixed in 2.237.3 ## Suggested inspection (read-only) - `python -m pip show sagemaker`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sagemaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-32g6-mg92-ghm2 (OSV record GHSA-32g6-mg92-ghm2 lists affected ranges: PyPI sagemaker >=0 <2.237.3 (fixed)) - Verified: https://github.com/advisories/GHSA-32g6-mg92-ghm2 (GitHub-reviewed advisory GHSA-32g6-mg92-ghm2 lists affected ranges: PyPI sagemaker >=0 <2.237.3) Commands are suggestions: review each one before running it.
Loading voting…