Skip to content

← Actionable
Medium, CVSS 6.2

Node Denial of Service via kubelet Checkpoint API

CVE-2025-0426GHSA-jgfp-53c3-624w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.32.2, 1.31.6, 1.30.10, 1.29.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    >= 1.32.0, < 1.32.2>= 1.31.0, < 1.31.6>= 1.30.0, < 1.30.10< 1.29.14
    Fixed in
    1.32.2, 1.31.6, 1.29.14, 1.30.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-0426: 0.37% estimated exploitation activity in the next 30 days; percentile 31.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security issue was discovered in Kubernetes where a large number of container checkpoint requests made to the unauthenticated kubelet read-only HTTP endpoint may cause a Node Denial of Service by filling the Node's disk.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jgfp-53c3-624w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-0426

Advisory: Node Denial of Service via kubelet Checkpoint API
IDs: CVE-2025-0426, GHSA-jgfp-53c3-624w
Record: https://patchnext.com/advisories/cve-2025-0426 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.32.2, 1.31.6, 1.30.10, 1.29.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected >= 1.32.0, < 1.32.2; >= 1.31.0, < 1.31.6; >= 1.30.0, < 1.30.10; < 1.29.14; fixed in 1.32.2, 1.31.6, 1.29.14, 1.30.10

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jgfp-53c3-624w (GitHub-reviewed advisory GHSA-jgfp-53c3-624w lists affected ranges: Go k8s.io/kubernetes >=1.32.0 =1.31.0 =1.30.0 =0 <1.29.14)

Commands are suggestions: review each one before running it.

Loading voting…