Skip to content

← Actionable
Medium, CVSS 5.3

Eclipse Jetty has a denial of service vulnerability on DosFilter

CVE-2024-9823GHSA-j26w-f9rq-mr2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-servlets 11.0.18, 10.0.18, 9.4.54; org.eclipse.jetty.ee9:jetty-ee9-servlets 12.0.3; org.eclipse.jetty.ee8:jetty-ee8-servlets 12.0.3; org.eclipse.jetty.ee10:jetty-ee10-servlets 12.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j26w-f9rq-mr2q lists affected ranges: Maven org.eclipse.jetty.ee10:jetty-ee10-servlets >=12.0.0 =12.0.0 =12.0.0 =9.0.0 =10.0.0 =11.0.0 <11.0.18

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-9823: 0.94% estimated exploitation activity in the next 30 days; percentile 60.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description There exists a security vulnerability in Jetty's DosFilter which can be exploited by unauthorized users to cause remote denial-of-service (DoS) attack on the server using DosFilter. By repeatedly sending crafted requests, attackers can trigger OutofMemory errors and exhaust the server's memory finally. Vulnerability details The Jetty DoSFilter (Denial of Service Filter) is a security filter designed to protect web applications against certain types of Denial of Service (DoS) attacks and other abusive behavior. It helps to mitigate excessive resource consumption by limiting the rate at which clients can make requests to the server. The DoSFilter monitors and tracks client request patterns, including request rates, and can take actions such as blocking or delaying requests from clients that exceed predefined thresholds. The internal tracking of requests in DoSFilter is the source of this OutOfMemory condition. Impact Users of the DoSFilter may be subject to DoS attacks that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j26w-f9rq-mr2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-9823

Advisory: Eclipse Jetty has a denial of service vulnerability on DosFilter
IDs: CVE-2024-9823, GHSA-j26w-f9rq-mr2q
Record: https://patchnext.com/advisories/cve-2024-9823 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-servlets 11.0.18, 10.0.18, 9.4.54; org.eclipse.jetty.ee9:jetty-ee9-servlets 12.0.3; org.eclipse.jetty.ee8:jetty-ee8-servlets 12.0.3; org.eclipse.jetty.ee10:jetty-ee10-servlets 12.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-servlets: affected >= 9.0.0, < 9.4.54; >= 10.0.0, < 10.0.18; >= 11.0.0, < 11.0.18; fixed in 10.0.18, 11.0.18, 9.4.54
- Maven org.eclipse.jetty.ee9:jetty-ee9-servlets: affected >= 12.0.0, < 12.0.3; fixed in 12.0.3
- Maven org.eclipse.jetty.ee8:jetty-ee8-servlets: affected >= 12.0.0, < 12.0.3; fixed in 12.0.3
- Maven org.eclipse.jetty.ee10:jetty-ee10-servlets: affected >= 12.0.0, < 12.0.3; fixed in 12.0.3

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee9:jetty-ee9-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee8:jetty-ee8-servlets: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee10:jetty-ee10-servlets: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-servlets, org.eclipse.jetty.ee9:jetty-ee9-servlets, org.eclipse.jetty.ee8:jetty-ee8-servlets, org.eclipse.jetty.ee10:jetty-ee10-servlets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j26w-f9rq-mr2q (GitHub-reviewed advisory GHSA-j26w-f9rq-mr2q lists affected ranges: Maven org.eclipse.jetty.ee10:jetty-ee10-servlets >=12.0.0 =12.0.0 =12.0.0 =9.0.0 =10.0.0 =11.0.0 <11.0.18)

Commands are suggestions: review each one before running it.

Loading voting…