Kedro deserialization vulnerability
CVE-2024-9701GHSA-747f-ww56-4q4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kedro 0.19.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI kedro
- Affected
- < 0.19.9
- Fixed in
- 0.19.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-747f-ww56-4q4h lists affected ranges: PyPI kedro >=0 <0.19.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-747f-ww56-4q4h lists affected ranges: PyPI kedro >=0 <0.19.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-9701: 1.14% estimated exploitation activity in the next 30 days; percentile 66.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Remote Code Execution (RCE) vulnerability has been identified in the Kedro ShelveStore class (version 0.19.8). This vulnerability allows an attacker to execute arbitrary Python code via deserialization of malicious payloads, potentially leading to a full system compromise. The ShelveStore class uses Python's shelve module to manage session data, which relies on pickle for serialization. Crafting a malicious payload and storing it in the shelve file can lead to RCE when the payload is deserialized.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-747f-ww56-4q4h
- Revision 1 · created ·
Published from osv record GHSA-747f-ww56-4q4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-9701 Advisory: Kedro deserialization vulnerability IDs: CVE-2024-9701, GHSA-747f-ww56-4q4h Record: https://patchnext.com/advisories/cve-2024-9701 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kedro 0.19.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI kedro: affected < 0.19.9; fixed in 0.19.9 ## Suggested inspection (read-only) - `python -m pip show kedro`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kedro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-747f-ww56-4q4h (OSV record GHSA-747f-ww56-4q4h lists affected ranges: PyPI kedro >=0 <0.19.9 (fixed)) - Verified: https://github.com/advisories/GHSA-747f-ww56-4q4h (GitHub-reviewed advisory GHSA-747f-ww56-4q4h lists affected ranges: PyPI kedro >=0 <0.19.9) Commands are suggestions: review each one before running it.
Loading voting…