Skip to content

← Actionable
High, CVSS 7.5amended

LiteLLM Reveals Portion of API Key via a Logging File

CVE-2024-9606GHSA-g5pg-73fc-hjwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.44.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    < 1.44.12
    Fixed in
    1.44.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-9606: 0.77% estimated exploitation activity in the next 30 days; percentile 55.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In berriai/litellm before version 1.44.12, the litellm/litellmcoreutils/litellmlogging.py file contains a vulnerability where the API key masking code only masks the first 5 characters of the key. This results in the leakage of almost the entire API key in the logs, exposing a significant amount of the secret key. The issue affects version v1.44.9.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g5pg-73fc-hjwq

  2. Revision 1 · created ·

    Published from osv record GHSA-g5pg-73fc-hjwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-9606

Advisory: LiteLLM Reveals Portion of API Key via a Logging File
IDs: CVE-2024-9606, GHSA-g5pg-73fc-hjwq
Record: https://patchnext.com/advisories/cve-2024-9606 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.44.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected < 1.44.12; fixed in 1.44.12

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5pg-73fc-hjwq (OSV record GHSA-g5pg-73fc-hjwq lists affected ranges: PyPI litellm >=0 <1.44.12 (fixed))
- Verified: https://github.com/advisories/GHSA-g5pg-73fc-hjwq (GitHub-reviewed advisory GHSA-g5pg-73fc-hjwq lists affected ranges: PyPI litellm >=0 <1.44.12)

Commands are suggestions: review each one before running it.

Loading voting…