ReDoS vulnerability in vue package that is exploitable through inefficient regex evaluation in the parseHTML function
CVE-2024-9506GHSA-5j4c-8p2g-v4jx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vue 3.0.0-alpha.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vue
- Affected
- >= 2.0.0-alpha.1, < 3.0.0-alpha.0
- Fixed in
- 3.0.0-alpha.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5j4c-8p2g-v4jx lists affected ranges: npm vue >=2.0.0-alpha.1 <3.0.0-alpha.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5j4c-8p2g-v4jx lists affected ranges: npm vue >=2.0.0-alpha.1 <3.0.0-alpha.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-9506: 0.57% estimated exploitation activity in the next 30 days; percentile 47.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The ReDoS can be exploited through the parseHTML function in the html-parser.ts file. This flaw allows attackers to slow down the application by providing specially crafted input that causes inefficient processing of regular expressions, leading to excessive resource consumption. To demonstrate this vulnerability, here's an example. In a Vue client-side application, create a new Vue instance with a template string that includes a <script tag but closes it incorrectly with something like </textarea. Next, set up a basic HTML page (e.g., index.html) to load this JavaScript and mount the Vue instance: When you visit the app in your browser at http://localhost:3000, you'll notice that the time taken to parse and mount the Vue application increases significantly due to the ReDoS vulnerability, demonstrating how the flaw can affect performance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5j4c-8p2g-v4jx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5j4c-8p2g-v4jx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-9506 Advisory: ReDoS vulnerability in vue package that is exploitable through inefficient regex evaluation in the parseHTML function IDs: CVE-2024-9506, GHSA-5j4c-8p2g-v4jx Record: https://patchnext.com/advisories/cve-2024-9506 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vue 3.0.0-alpha.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vue: affected >= 2.0.0-alpha.1, < 3.0.0-alpha.0; fixed in 3.0.0-alpha.0 ## Suggested inspection (read-only) - `npm ls vue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5j4c-8p2g-v4jx (OSV record GHSA-5j4c-8p2g-v4jx lists affected ranges: npm vue >=2.0.0-alpha.1 <3.0.0-alpha.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5j4c-8p2g-v4jx (GitHub-reviewed advisory GHSA-5j4c-8p2g-v4jx lists affected ranges: npm vue >=2.0.0-alpha.1 <3.0.0-alpha.0) Commands are suggestions: review each one before running it.
Loading voting…