LiteLLM Vulnerable to Denial of Service (DoS) via Crafted HTTP Request
CVE-2024-8984GHSA-fh2c-86xm-pm2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.56.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.56.2
- Fixed in
- 1.56.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fh2c-86xm-pm2x lists affected ranges: PyPI litellm >=0 <1.56.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fh2c-86xm-pm2x lists affected ranges: PyPI litellm >=0 <1.56.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-8984: 0.86% estimated exploitation activity in the next 30 days; percentile 58.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fh2c-86xm-pm2x
- Revision 1 · created ·
Published from osv record GHSA-fh2c-86xm-pm2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-8984 Advisory: LiteLLM Vulnerable to Denial of Service (DoS) via Crafted HTTP Request IDs: CVE-2024-8984, GHSA-fh2c-86xm-pm2x Record: https://patchnext.com/advisories/cve-2024-8984 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.56.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.56.2; fixed in 1.56.2 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fh2c-86xm-pm2x (OSV record GHSA-fh2c-86xm-pm2x lists affected ranges: PyPI litellm >=0 <1.56.2 (fixed)) - Verified: https://github.com/advisories/GHSA-fh2c-86xm-pm2x (GitHub-reviewed advisory GHSA-fh2c-86xm-pm2x lists affected ranges: PyPI litellm >=0 <1.56.2) Commands are suggestions: review each one before running it.
Loading voting…