Skip to content

← Actionable
Medium, CVSS 6.9amended

D-Tale Command Execution Vulnerability

CVE-2024-8862GHSA-fg5m-m723-7mv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dtale 3.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dtale

    Affected
    < 3.14.1
    Fixed in
    3.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2024-8862: 1.33% estimated exploitation activity in the next 30 days; percentile 71.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

D-Tale is the combination of a Flask back-end and a React front-end to bring you an easy way to view & analyze Pandas data structures. In dtale\views.py, under the route @dtale.route("/chart-data/<dataid"), the query parameters from the request are directly passed into runquery for execution. And the runquery function calls proceed without performing any processing or sanitization of the query parameter. As a result, the query is directly used in the df.query method for data retrieval. Tthe engine used is python, which allows executing the query expression ans leading to a command execution vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fg5m-m723-7mv6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fg5m-m723-7mv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-8862

Advisory: D-Tale Command Execution Vulnerability
IDs: CVE-2024-8862, GHSA-fg5m-m723-7mv6
Record: https://patchnext.com/advisories/cve-2024-8862 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dtale 3.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dtale: affected < 3.14.1; fixed in 3.14.1

## Suggested inspection (read-only)
- `python -m pip show dtale`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dtale.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fg5m-m723-7mv6 (OSV record GHSA-fg5m-m723-7mv6 lists affected ranges: PyPI dtale >=0 <3.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fg5m-m723-7mv6 (GitHub-reviewed advisory GHSA-fg5m-m723-7mv6 lists affected ranges: PyPI dtale >=0 <3.14.1)

Commands are suggestions: review each one before running it.

Loading voting…