Eclipse Jetty's ThreadLimitHandler.getRemote() vulnerable to remote DoS attacks
CVE-2024-8184GHSA-g8m5-722r-8whq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-server 12.0.9, 11.0.24, 10.0.24, 9.4.56), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty:jetty-server
- Affected
- >= 12.0.0, <= 12.0.8>= 10.0.0, <= 10.0.23>= 11.0.0, <= 11.0.23>= 9.3.12, <= 9.4.55
- Fixed in
- 10.0.24, 11.0.24, 12.0.9, 9.4.56
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8m5-722r-8whq lists affected ranges: Maven org.eclipse.jetty:jetty-server >=12.0.0 =10.0.0 =11.0.0 =9.3.12 <=9.4.55
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-8184: 1.03% estimated exploitation activity in the next 30 days; percentile 63.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Remote DOS attack can cause out of memory Description There exists a security vulnerability in Jetty's ThreadLimitHandler.getRemote() which can be exploited by unauthorized users to cause remote denial-of-service (DoS) attack. By repeatedly sending crafted requests, attackers can trigger OutofMemory errors and exhaust the server's memory. Affected Versions Jetty 12.0.0-12.0.8 (Supported) Jetty 11.0.0-11.0.23 (EOL) Jetty 10.0.0-10.0.23 (EOL) Jetty 9.3.12-9.4.55 (EOL) Patched Versions Jetty 12.0.9 Jetty 11.0.24 Jetty 10.0.24 Jetty 9.4.56 Workarounds Do not use ThreadLimitHandler. Consider use of QoSHandler instead to artificially limit resource utilization. References Jetty 12 - https://github.com/jetty/jetty.project/pull/11723
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g8m5-722r-8whq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-8184 Advisory: Eclipse Jetty's ThreadLimitHandler.getRemote() vulnerable to remote DoS attacks IDs: CVE-2024-8184, GHSA-g8m5-722r-8whq Record: https://patchnext.com/advisories/cve-2024-8184 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-server 12.0.9, 11.0.24, 10.0.24, 9.4.56. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty:jetty-server: affected >= 12.0.0, <= 12.0.8; >= 10.0.0, <= 10.0.23; >= 11.0.0, <= 11.0.23; >= 9.3.12, <= 9.4.55; fixed in 10.0.24, 11.0.24, 12.0.9, 9.4.56 ## Suggested inspection (read-only) - Maven org.eclipse.jetty:jetty-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty:jetty-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g8m5-722r-8whq (GitHub-reviewed advisory GHSA-g8m5-722r-8whq lists affected ranges: Maven org.eclipse.jetty:jetty-server >=12.0.0 =10.0.0 =11.0.0 =9.3.12 <=9.4.55) Commands are suggestions: review each one before running it.
Loading voting…