Skip to content

← Actionable
High, CVSS 7.2amended

pretix Stored Cross-site Scripting vulnerability

CVE-2024-8113GHSA-45rp-q25w-4426

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2024.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pretix

    Affected
    < 2024.7.1
    Fixed in
    2024.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:U/V:X/RE:L/U:Green · score source
EPSS
  • CVE-2024-8113: 0.32% estimated exploitation activity in the next 30 days; percentile 25.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Stored XSS in organizer and event settings of pretix up to 2024.7.0 allows malicious event organizers to inject HTML tags into e-mail previews on settings page. The default Content Security Policy of pretix prevents execution of attacker-provided scripts, making exploitation unlikely. However, combined with a CSP bypass (which is not currently known) the vulnerability could be used to impersonate other organizers or staff users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-45rp-q25w-4426

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-45rp-q25w-4426

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-8113

Advisory: pretix Stored Cross-site Scripting vulnerability
IDs: CVE-2024-8113, GHSA-45rp-q25w-4426
Record: https://patchnext.com/advisories/cve-2024-8113 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pretix 2024.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pretix: affected < 2024.7.1; fixed in 2024.7.1

## Suggested inspection (read-only)
- `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pretix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-45rp-q25w-4426 (OSV record GHSA-45rp-q25w-4426 lists affected ranges: PyPI pretix >=0 <2024.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-45rp-q25w-4426 (GitHub-reviewed advisory GHSA-45rp-q25w-4426 lists affected ranges: PyPI pretix >=0 <2024.7.1)

Commands are suggestions: review each one before running it.

Loading voting…