Vulnerable juju hook tool abstract UNIX domain socket
CVE-2024-8037GHSA-8v4w-f4r9-7h6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/juju/juju 0.0.0-20240820065804-2f2ec128ef5a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.0-20240820065804-2f2ec128ef5a
- Fixed in
- 0.0.0-20240820065804-2f2ec128ef5a
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8v4w-f4r9-7h6x lists affected ranges: Go github.com/juju/juju >=0 <0.0.0-20240820065804-2f2ec128ef5a
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:H/SA:H · score source
- EPSS
- CVE-2024-8037: 0.19% estimated exploitation activity in the next 30 days; percentile 8.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When combined with an attack of JUJUCONTEXTID, any user on the local system with access to the default network namespace may connect to the @/var/lib/juju/agents/unit-xxxx-yyyy/agent.socket and perform actions that are normally reserved to a juju charm. Patches Patch: https://github.com/juju/juju/commit/2f2ec128ef5a8ca81fc86ae79cfcdbab0007c206 Patched in: - 3.5.4 - 3.4.6 - 3.3.7 - 3.1.10 - 2.9.51 Workarounds No workarounds available. References GHSA-mh98-763h-m9v4 https://github.com/juju/juju/blob/725800953aaa29dbeda4f806097bf838e61644dd/worker/uniter/paths.go#L222
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8v4w-f4r9-7h6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-8037 Advisory: Vulnerable juju hook tool abstract UNIX domain socket IDs: CVE-2024-8037, GHSA-8v4w-f4r9-7h6x Record: https://patchnext.com/advisories/cve-2024-8037 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/juju/juju 0.0.0-20240820065804-2f2ec128ef5a. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/juju/juju: affected < 0.0.0-20240820065804-2f2ec128ef5a; fixed in 0.0.0-20240820065804-2f2ec128ef5a ## Suggested inspection (read-only) - Go github.com/juju/juju: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/juju/juju. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8v4w-f4r9-7h6x (GitHub-reviewed advisory GHSA-8v4w-f4r9-7h6x lists affected ranges: Go github.com/juju/juju >=0 <0.0.0-20240820065804-2f2ec128ef5a) Commands are suggestions: review each one before running it.
Loading voting…