Open WebUI Cross-Site Request Forgery (CSRF) Vulnerability
CVE-2024-7806GHSA-85jc-8h5p-8vw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.3.33), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.3.33
- Fixed in
- 0.3.33
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-85jc-8h5p-8vw8 lists affected ranges: PyPI open-webui >=0 <0.3.33 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-85jc-8h5p-8vw8 lists affected ranges: PyPI open-webui >=0 <0.3.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in open-webui/open-webui versions <= 0.3.8 allows remote code execution by non-admin users via Cross-Site Request Forgery (CSRF). The application uses cookies with the SameSite attribute set to lax for authentication and lacks CSRF tokens. This allows an attacker to craft a malicious HTML that, when accessed by a victim, can modify the Python code of an existing pipeline and execute arbitrary code with the victim's privileges.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-85jc-8h5p-8vw8
- Revision 1 · created ·
Published from osv record GHSA-85jc-8h5p-8vw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-7806 Advisory: Open WebUI Cross-Site Request Forgery (CSRF) Vulnerability IDs: CVE-2024-7806, GHSA-85jc-8h5p-8vw8 Record: https://patchnext.com/advisories/cve-2024-7806 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.3.33. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.3.33; fixed in 0.3.33 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-85jc-8h5p-8vw8 (OSV record GHSA-85jc-8h5p-8vw8 lists affected ranges: PyPI open-webui >=0 <0.3.33 (fixed)) - Verified: https://github.com/advisories/GHSA-85jc-8h5p-8vw8 (GitHub-reviewed advisory GHSA-85jc-8h5p-8vw8 lists affected ranges: PyPI open-webui >=0 <0.3.33) Commands are suggestions: review each one before running it.
Loading voting…