Skip to content

← Actionable
High, CVSS 8.7

protobuf-java has potential Denial of Service issue

CVE-2024-7254GHSA-735f-pc8j-v9w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.google.protobuf:protobuf-kotlin 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-java 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-javalite 4.28.2, 4.27.5, 3.25.5; google-protobuf 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-kotlin-lite 4.28.2, 4.27.5, 3.25.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-735f-pc8j-v9w8 lists affected ranges: Maven com.google.protobuf:protobuf-java >=0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-7254: 2.77% estimated exploitation activity in the next 30 days; percentile 86.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When parsing unknown fields in the Protobuf Java Lite and Full library, a maliciously crafted message can cause a StackOverflow error and lead to a program crash. Reporter: Alexis Challande, Trail of Bits Ecosystem Security Team <ecosystem@trailofbits.com Affected versions: This issue affects all versions of both the Java full and lite Protobuf runtimes, as well as Protobuf for Kotlin and JRuby, which themselves use the Java Protobuf runtime. Severity CVE-2024-7254 High CVSS4.0 Score 8.7 (NOTE: there may be a delay in publication) This is a potential Denial of Service. Parsing nested groups as unknown fields with DiscardUnknownFieldsParser or Java Protobuf Lite parser, or against Protobuf map fields, creates unbounded recursions that can be abused by an attacker. Proof of Concept For reproduction details, please refer to the unit tests (Protobuf Java LiteTest and CodedInputStreamTest) that identify the specific inputs that exercise this parsing weakness. Remediation and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-735f-pc8j-v9w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-7254

Advisory: protobuf-java has potential Denial of Service issue
IDs: CVE-2024-7254, GHSA-735f-pc8j-v9w8
Record: https://patchnext.com/advisories/cve-2024-7254 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.google.protobuf:protobuf-kotlin 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-java 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-javalite 4.28.2, 4.27.5, 3.25.5; google-protobuf 4.28.2, 4.27.5, 3.25.5; com.google.protobuf:protobuf-kotlin-lite 4.28.2, 4.27.5, 3.25.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.google.protobuf:protobuf-kotlin: affected < 3.25.5; >= 4.0.0-RC1, < 4.27.5; >= 4.28.0-RC1, < 4.28.2; fixed in 3.25.5, 4.27.5, 4.28.2
- Maven com.google.protobuf:protobuf-java: affected < 3.25.5; >= 4.0.0-RC1, < 4.27.5; >= 4.28.0-RC1, < 4.28.2; fixed in 3.25.5, 4.27.5, 4.28.2
- Maven com.google.protobuf:protobuf-javalite: affected < 3.25.5; >= 4.0.0-RC1, < 4.27.5; >= 4.28.0-RC1, < 4.28.2; fixed in 3.25.5, 4.27.5, 4.28.2
- RubyGems google-protobuf: affected < 3.25.5; >= 4.0.0.rc.1, < 4.27.5; >= 4.28.0.rc.1, < 4.28.2; fixed in 3.25.5, 4.27.5, 4.28.2
- Maven com.google.protobuf:protobuf-kotlin-lite: affected < 3.25.5; >= 4.0.0-RC1, < 4.27.5; >= 4.28.0-RC1, < 4.28.2; fixed in 3.25.5, 4.27.5, 4.28.2

## Suggested inspection (read-only)
- Maven com.google.protobuf:protobuf-kotlin: check the installed version with your package manager.
- Maven com.google.protobuf:protobuf-java: check the installed version with your package manager.
- Maven com.google.protobuf:protobuf-javalite: check the installed version with your package manager.
- RubyGems google-protobuf: check the installed version with your package manager.
- Maven com.google.protobuf:protobuf-kotlin-lite: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.google.protobuf:protobuf-kotlin, com.google.protobuf:protobuf-java, com.google.protobuf:protobuf-javalite, google-protobuf, com.google.protobuf:protobuf-kotlin-lite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-735f-pc8j-v9w8 (GitHub-reviewed advisory GHSA-735f-pc8j-v9w8 lists affected ranges: Maven com.google.protobuf:protobuf-java >=0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0 =4.0.0-RC1 =4.28.0-RC1 =0…)

Commands are suggestions: review each one before running it.

Loading voting…