Skip to content

← Actionable
Medium, CVSS 4.2

WSO2 products vulnerable to privilege escalation due to business logic flaw in SOAP admin services

CVE-2024-7096GHSA-j63j-7r7r-5v4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wso2.am:am-parent 4.4.0; org.wso2.is:identity-server-parent 7.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-7096: 0.74% estimated exploitation activity in the next 30 days; percentile 54.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A privilege escalation vulnerability exists in multiple WSO2 products due to a business logic flaw in SOAP admin services. A malicious actor can create a new user with elevated permissions only when all of the following conditions are met: SOAP admin services are accessible to the attacker. The deployment includes an internally used attribute that is not part of the default WSO2 product configuration. At least one custom role exists with non-default permissions. The attacker has knowledge of the custom role and the internal attribute used in the deployment. Exploiting this vulnerability allows malicious actors to assign higher privileges to self-registered users, bypassing intended access control mechanisms.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j63j-7r7r-5v4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-7096

Advisory: WSO2 products vulnerable to privilege escalation due to business logic flaw in SOAP admin services
IDs: CVE-2024-7096, GHSA-j63j-7r7r-5v4j
Record: https://patchnext.com/advisories/cve-2024-7096 (revision 1, source checked 26 Oct 2026, 16:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wso2.am:am-parent 4.4.0; org.wso2.is:identity-server-parent 7.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wso2.am:am-parent: affected >= 2.0.0, <= 4.3.0; fixed in 4.4.0
- Maven org.wso2.is:identity-server-parent: affected >= 5.2.0, <= 7.0.0; fixed in 7.1.0

## Suggested inspection (read-only)
- Maven org.wso2.am:am-parent: check the installed version with your package manager.
- Maven org.wso2.is:identity-server-parent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wso2.am:am-parent, org.wso2.is:identity-server-parent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j63j-7r7r-5v4j (GitHub-reviewed advisory GHSA-j63j-7r7r-5v4j lists affected ranges: Maven org.wso2.am:am-parent >=2.0.0 =5.2.0 <=7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…