open-webui Insecure Direct Object Reference (IDOR) vulnerability
CVE-2024-7041GHSA-xcvc-5hgv-phqg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.6.3
- Fixed in
- 0.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <=0.3.8
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <=0.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <0.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <0.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-7041: 0.37% estimated exploitation activity in the next 30 days; percentile 30.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An Insecure Direct Object Reference (IDOR) vulnerability exists in open-webui/open-webui version v0.3.8. The vulnerability occurs in the API endpoint `http://0.0.0.0:3000/api/v1/memories/{id}/update`, where the decentralization design is flawed, allowing attackers to edit other users' memories without proper authorization.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-xcvc-5hgv-phqg
- Revision 4 · amended ·
Amended from ghsa record GHSA-xcvc-5hgv-phqg
- Revision 3 · amended ·
Amended from ghsa record GHSA-xcvc-5hgv-phqg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xcvc-5hgv-phqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-7041 Advisory: open-webui Insecure Direct Object Reference (IDOR) vulnerability IDs: CVE-2024-7041, GHSA-xcvc-5hgv-phqg Record: https://patchnext.com/advisories/cve-2024-7041 (revision 5, source checked 27 Oct 2026, 06:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.6.3; fixed in 0.6.3 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xcvc-5hgv-phqg (OSV record GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <=0.3.8) - Verified: https://github.com/advisories/GHSA-xcvc-5hgv-phqg (GitHub-reviewed advisory GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <=0.3.8) - Verified: https://github.com/advisories/GHSA-xcvc-5hgv-phqg (GitHub-reviewed advisory GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <0.6.3) - Verified: https://osv.dev/vulnerability/GHSA-xcvc-5hgv-phqg (OSV record GHSA-xcvc-5hgv-phqg lists affected ranges: PyPI open-webui >=0 <0.6.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…