LoLLMS Code Injection vulnerability
CVE-2024-6982GHSA-jccx-m9v4-9hwh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lollms 11.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lollms
- Affected
- < 11.0.0
- Fixed in
- 11.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jccx-m9v4-9hwh lists affected ranges: PyPI lollms >=0 <11.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jccx-m9v4-9hwh lists affected ranges: PyPI lollms >=0 <11.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-6982: 0.46% estimated exploitation activity in the next 30 days; percentile 39.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's eval() function to evaluate mathematical expressions within a Python sandbox that disables builtins and only allows functions from the math module. This sandbox can be bypassed by loading the os module using the frozenimportlib.BuiltinImporter class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jccx-m9v4-9hwh
- Revision 1 · created ·
Published from osv record GHSA-jccx-m9v4-9hwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6982 Advisory: LoLLMS Code Injection vulnerability IDs: CVE-2024-6982, GHSA-jccx-m9v4-9hwh Record: https://patchnext.com/advisories/cve-2024-6982 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lollms 11.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lollms: affected < 11.0.0; fixed in 11.0.0 ## Suggested inspection (read-only) - `python -m pip show lollms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lollms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jccx-m9v4-9hwh (OSV record GHSA-jccx-m9v4-9hwh lists affected ranges: PyPI lollms >=0 <11.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jccx-m9v4-9hwh (GitHub-reviewed advisory GHSA-jccx-m9v4-9hwh lists affected ranges: PyPI lollms >=0 <11.0.0) Commands are suggestions: review each one before running it.
Loading voting…