Gitea Cross-site Scripting Vulnerability
CVE-2024-6886GHSA-4h4p-553m-46qh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.22.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.22.1
- Fixed in
- 1.22.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4h4p-553m-46qh lists affected ranges: Go code.gitea.io/gitea >=0 <1.22.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-6886: 32.97% estimated exploitation activity in the next 30 days; percentile 98.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Gitea Gitea Open Source Git Server allows Stored XSS.This issue affects Gitea Open Source Git Server: 1.22.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4h4p-553m-46qh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6886 Advisory: Gitea Cross-site Scripting Vulnerability IDs: CVE-2024-6886, GHSA-4h4p-553m-46qh Record: https://patchnext.com/advisories/cve-2024-6886 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.22.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go code.gitea.io/gitea: affected < 1.22.1; fixed in 1.22.1 ## Suggested inspection (read-only) - Go code.gitea.io/gitea: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code.gitea.io/gitea. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4h4p-553m-46qh (GitHub-reviewed advisory GHSA-4h4p-553m-46qh lists affected ranges: Go code.gitea.io/gitea >=0 <1.22.1) Commands are suggestions: review each one before running it.
Loading voting…