Flask-CORS allows for inconsistent CORS matching
CVE-2024-6844GHSA-8vgw-p6qm-5gr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-cors 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-cors
- Affected
- <= 5.0.1
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8vgw-p6qm-5gr7 lists affected ranges: PyPI flask-cors >=0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vgw-p6qm-5gr7 lists affected ranges: PyPI flask-cors >=0 <=5.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-6844: 0.32% estimated exploitation activity in the next 30 days; percentile 24.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in corydolphin/flask-cors version 5.0.1 allows for inconsistent CORS matching due to the handling of the '+' character in URL paths. The request.path is passed through the unquoteplus function, which converts the '+' character to a space ' '. This behavior leads to incorrect path normalization, causing potential mismatches in CORS configuration. As a result, endpoints may not be matched correctly to their CORS settings, leading to unexpected CORS policy application. This can cause unauthorized cross-origin access or block valid requests, creating security vulnerabilities and usability issues.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8vgw-p6qm-5gr7
- Revision 1 · created ·
Published from osv record GHSA-8vgw-p6qm-5gr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6844 Advisory: Flask-CORS allows for inconsistent CORS matching IDs: CVE-2024-6844, GHSA-8vgw-p6qm-5gr7 Record: https://patchnext.com/advisories/cve-2024-6844 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-cors 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-cors: affected <= 5.0.1; fixed in 6.0.0 ## Suggested inspection (read-only) - `python -m pip show flask-cors`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-cors. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8vgw-p6qm-5gr7 (OSV record GHSA-8vgw-p6qm-5gr7 lists affected ranges: PyPI flask-cors >=0 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8vgw-p6qm-5gr7 (GitHub-reviewed advisory GHSA-8vgw-p6qm-5gr7 lists affected ranges: PyPI flask-cors >=0 <=5.0.1) Commands are suggestions: review each one before running it.
Loading voting…