Skip to content

← Actionable
High, CVSS 7.5amended

Gunicorn HTTP Request/Response Smuggling vulnerability

CVE-2024-6827GHSA-hc5x-x2vx-497g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gunicorn 22.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gunicorn

    Affected
    < 22.0.0
    Fixed in
    22.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-6827: 0.81% estimated exploitation activity in the next 30 days; percentile 56.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Gunicorn version 21.2.0 does not properly validate the value of the 'Transfer-Encoding' header as specified in the RFC standards, which leads to the default fallback method of 'Content-Length,' making it vulnerable to TE.CL request smuggling. This vulnerability can lead to cache poisoning, data exposure, session manipulation, SSRF, XSS, DoS, data integrity compromise, security bypass, information leakage, and business logic abuse.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hc5x-x2vx-497g

  2. Revision 1 · created ·

    Published from osv record GHSA-hc5x-x2vx-497g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-6827

Advisory: Gunicorn HTTP Request/Response Smuggling vulnerability
IDs: CVE-2024-6827, GHSA-hc5x-x2vx-497g
Record: https://patchnext.com/advisories/cve-2024-6827 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gunicorn 22.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gunicorn: affected < 22.0.0; fixed in 22.0.0

## Suggested inspection (read-only)
- `python -m pip show gunicorn`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gunicorn.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hc5x-x2vx-497g (OSV record GHSA-hc5x-x2vx-497g lists affected ranges: PyPI gunicorn >=0 <22.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hc5x-x2vx-497g (GitHub-reviewed advisory GHSA-hc5x-x2vx-497g lists affected ranges: PyPI gunicorn >=0 <22.0.0)

Commands are suggestions: review each one before running it.

Loading voting…