Open WebUI Stored Cross-Site Scripting Vulnerability
CVE-2024-6706GHSA-5jp3-wp5v-5363
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.3.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.3.14
- Fixed in
- 0.3.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <=0.1.105
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <=0.1.105
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <0.3.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <0.3.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-6706: 0.66% estimated exploitation activity in the next 30 days; percentile 51.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Attackers can craft a malicious prompt that coerces the language model into executing arbitrary JavaScript in the context of the web page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-5jp3-wp5v-5363
- Revision 4 · amended ·
Amended from ghsa record GHSA-5jp3-wp5v-5363
- Revision 3 · amended ·
Amended from ghsa record GHSA-5jp3-wp5v-5363
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5jp3-wp5v-5363
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6706 Advisory: Open WebUI Stored Cross-Site Scripting Vulnerability IDs: CVE-2024-6706, GHSA-5jp3-wp5v-5363 Record: https://patchnext.com/advisories/cve-2024-6706 (revision 5, source checked 27 Oct 2026, 06:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.3.14. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.3.14; fixed in 0.3.14 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5jp3-wp5v-5363 (OSV record GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <=0.1.105) - Verified: https://github.com/advisories/GHSA-5jp3-wp5v-5363 (GitHub-reviewed advisory GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <=0.1.105) - Verified: https://github.com/advisories/GHSA-5jp3-wp5v-5363 (GitHub-reviewed advisory GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <0.3.14) - Verified: https://osv.dev/vulnerability/GHSA-5jp3-wp5v-5363 (OSV record GHSA-5jp3-wp5v-5363 lists affected ranges: PyPI open-webui >=0 <0.3.14 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…