LiteLLM Server-Side Request Forgery (SSRF) vulnerability
CVE-2024-6587GHSA-g26j-5385-hhw3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.44.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.44.8
- Fixed in
- 1.44.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g26j-5385-hhw3 lists affected ranges: PyPI litellm >=0 <1.44.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g26j-5385-hhw3 lists affected ranges: PyPI litellm >=0 <1.44.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-6587: 34.38% estimated exploitation activity in the next 30 days; percentile 98.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10. This vulnerability allows users to specify the apibase parameter when making requests to POST /chat/completions, causing the application to send the request to the domain specified by apibase. This request includes the OpenAI API key. A malicious user can set the apibase to their own domain and intercept the OpenAI API key, leading to unauthorized access and potential misuse of the API key.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g26j-5385-hhw3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g26j-5385-hhw3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6587 Advisory: LiteLLM Server-Side Request Forgery (SSRF) vulnerability IDs: CVE-2024-6587, GHSA-g26j-5385-hhw3 Record: https://patchnext.com/advisories/cve-2024-6587 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.44.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.44.8; fixed in 1.44.8 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g26j-5385-hhw3 (OSV record GHSA-g26j-5385-hhw3 lists affected ranges: PyPI litellm >=0 <1.44.8 (fixed)) - Verified: https://github.com/advisories/GHSA-g26j-5385-hhw3 (GitHub-reviewed advisory GHSA-g26j-5385-hhw3 lists affected ranges: PyPI litellm >=0 <1.44.8) Commands are suggestions: review each one before running it.
Loading voting…