Skip to content

← Actionable
Medium, CVSS 4.1amended

Directus has an insecure object reference via PATH presets

CVE-2024-6534GHSA-3fff-gqw3-vj86

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    <= 10.13.1
    Fixed in
    10.13.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N
EPSS
  • CVE-2024-6534: 0.33% estimated exploitation activity in the next 30 days; percentile 26.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Directus v10.13.0 allows an authenticated external attacker to modify presets created by the same user to assign them to another user. This is possible because the application only validates the user parameter in the POST /presets request but not in the PATCH request. When chained with CVE-2024-6533, it could result in account takeover. This vulnerability occurs because the application only validates the user parameter in the POST /presets request but not in the PATCH request. PoC To exploit this vulnerability, we need to do the follow steps using a non-administrative, default role attacker account. 1. Create a preset for a collection. Store the preset id, or use it if it already exists from GET /presets. The following example will use the directusers preset. 2. Modify the presets via PATCH /presets/{id}. With the malicious configuration and the user ID to which you will assign the preset configuration. The user ID can be obtained from GET /users. The following example…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3fff-gqw3-vj86

  2. Revision 1 · created ·

    Published from osv record GHSA-3fff-gqw3-vj86

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-6534

Advisory: Directus has an insecure object reference via PATH presets
IDs: CVE-2024-6534, GHSA-3fff-gqw3-vj86
Record: https://patchnext.com/advisories/cve-2024-6534 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected <= 10.13.1; fixed in 10.13.2

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fff-gqw3-vj86 (OSV record GHSA-3fff-gqw3-vj86 lists affected ranges: npm directus >=0 <10.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3fff-gqw3-vj86 (GitHub-reviewed advisory GHSA-3fff-gqw3-vj86 lists affected ranges: npm directus >=0 <=10.13.1)

Commands are suggestions: review each one before running it.

Loading voting…