Directus has a DOM-Based cross-site scripting (XSS) via layout_options
CVE-2024-6533GHSA-9qrm-48qf-r2rw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 11.3.3
- Fixed in
- 11.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9qrm-48qf-r2rw lists affected ranges: npm directus >=0 <11.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9qrm-48qf-r2rw lists affected ranges: npm directus >=0 <11.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:L/A:N
- EPSS
- CVE-2024-6533: 0.38% estimated exploitation activity in the next 30 days; percentile 32.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Directus allows an authenticated attacker to save cross site scripting code to the database. This is possible because the application injects an attacker-controlled parameter that will be stored in the server and used by the client into an unsanitized DOM element. When chained with CVE-2024-6534, it could result in account takeover. PoC To exploit this vulnerability, we need to do the following steps using a non-administrative, default role attacker account. 1. Upload the following JavaScript file. Using the upload functionality at POST /files. This PoC will show an alert message. 2. Create a preset for a collection and store the preset ID. Or use a preset already created from GET /presets. The following example uses the directusers preset. When the user visits the view that uses the directususers preset, the JavaScript file will be executed. Notes: Need to use an iframe to execute the malicious JavaScript file to bypass the CSP policies. The payload structure is <iframe…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9qrm-48qf-r2rw
- Revision 1 · created ·
Published from osv record GHSA-9qrm-48qf-r2rw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6533 Advisory: Directus has a DOM-Based cross-site scripting (XSS) via layout_options IDs: CVE-2024-6533, GHSA-9qrm-48qf-r2rw Record: https://patchnext.com/advisories/cve-2024-6533 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 11.3.3; fixed in 11.3.3 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9qrm-48qf-r2rw (OSV record GHSA-9qrm-48qf-r2rw lists affected ranges: npm directus >=0 <11.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-9qrm-48qf-r2rw (GitHub-reviewed advisory GHSA-9qrm-48qf-r2rw lists affected ranges: npm directus >=0 <11.3.3) Commands are suggestions: review each one before running it.
Loading voting…