Skip to content

← Actionable
High, CVSS 7.5

Hashicorp Vault vulnerable to Improper Check or Handling of Exceptional Conditions

CVE-2024-6468GHSA-2qmw-pvf7-4mw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.17.2, 1.16.3, 1.15.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/hashicorp/vault

    Affected
    >= 1.16.0-rc1, < 1.16.3>= 1.17.0-rc1, < 1.17.2>= 1.10.0, < 1.15.12
    Fixed in
    1.15.12, 1.17.2, 1.16.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-6468: 0.49% estimated exploitation activity in the next 30 days; percentile 42.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vault and Vault Enterprise did not properly handle requests originating from unauthorized IP addresses when the TCP listener option, proxyprotocolbehavior, was set to denyunauthorized. When receiving a request from a source IP address that was not listed in proxyprotocolauthorizedaddrs, the Vault API server would shut down and no longer respond to any HTTP requests, potentially resulting in denial of service. While this bug also affected versions of Vault up to 1.17.1 and 1.16.5, a separate regression in those release series did not allow Vault operators to configure the denyunauthorized option, thus not allowing the conditions for the denial of service to occur. Fixed in Vault and Vault Enterprise 1.17.2, 1.16.6, and 1.15.12

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2qmw-pvf7-4mw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-6468

Advisory: Hashicorp Vault vulnerable to Improper Check or Handling of Exceptional Conditions
IDs: CVE-2024-6468, GHSA-2qmw-pvf7-4mw6
Record: https://patchnext.com/advisories/cve-2024-6468 (revision 1, source checked 26 Oct 2026, 15:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.17.2, 1.16.3, 1.15.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/hashicorp/vault: affected >= 1.16.0-rc1, < 1.16.3; >= 1.17.0-rc1, < 1.17.2; >= 1.10.0, < 1.15.12; fixed in 1.15.12, 1.17.2, 1.16.3

## Suggested inspection (read-only)
- Go github.com/hashicorp/vault: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/hashicorp/vault.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qmw-pvf7-4mw6 (GitHub-reviewed advisory GHSA-2qmw-pvf7-4mw6 lists affected ranges: Go github.com/hashicorp/vault >=1.16.0-rc1 =1.17.0-rc1 =1.10.0 <1.15.12)

Commands are suggestions: review each one before running it.

Loading voting…