lxd has a restricted TLS certificate privilege escalation when in PKI mode
CVE-2024-6219GHSA-jpmc-7p9c-4rxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/canonical/lxd 0.0.0-20240403103450-0e7f2b5bf4d2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.0-20240403103450-0e7f2b5bf4d2
- Fixed in
- 0.0.0-20240403103450-0e7f2b5bf4d2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpmc-7p9c-4rxf lists affected ranges: Go github.com/canonical/lxd >=0 <0.0.0-20240403103450-0e7f2b5bf4d2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2024-6219: 0.16% estimated exploitation activity in the next 30 days; percentile 4.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If a server.ca file is present in LXDDIR at LXD start up, LXD is in "PKI mode". In this mode, all clients must have certificates that have been signed by the CA. The LXD configuration option core.trustcacertificates defaults to false. This means that although the client certificate has been signed by the CA, LXD will additionally add the certificate to the trust store and verify it via mTLS. When a restricted certificate is added to the trust store in this mode, it's restrictions are not honoured, and the client has full access to LXD. Details When authorization was refactored to allow for generalisation (at the time for TLS, RBAC, and OpenFGA, see https://github.com/canonical/lxd/pull/12313), PKI mode did not account for the core.trustcacertificates configuration option. When this option is enabled, all CA-signed client certificates are given full access to LXD. This cherry-pick from Incus was added to LXD to fix the issue. The cherry-pick fixed the immediate issue and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpmc-7p9c-4rxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-6219 Advisory: lxd has a restricted TLS certificate privilege escalation when in PKI mode IDs: CVE-2024-6219, GHSA-jpmc-7p9c-4rxf Record: https://patchnext.com/advisories/cve-2024-6219 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/canonical/lxd 0.0.0-20240403103450-0e7f2b5bf4d2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/canonical/lxd: affected < 0.0.0-20240403103450-0e7f2b5bf4d2; fixed in 0.0.0-20240403103450-0e7f2b5bf4d2 ## Suggested inspection (read-only) - Go github.com/canonical/lxd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/canonical/lxd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpmc-7p9c-4rxf (GitHub-reviewed advisory GHSA-jpmc-7p9c-4rxf lists affected ranges: Go github.com/canonical/lxd >=0 <0.0.0-20240403103450-0e7f2b5bf4d2) Commands are suggestions: review each one before running it.
Loading voting…